Teamspeak Viewer Trying to access array offset on value of type bool

  • Hallo,


    erst einmal vielen Dank für den tollen Teamspeak Viewer, wirklich ein klasse Produkt.




    Leider erhalte ich seit der Umstellung auf PHP 7.4 folgende Meldung:


    Installiert sind die folgenden aktuellen Versionen des TS Viewers:


    Teamspeak³ Channel Viewer 1.2.0 pl 1

    Teamspeak³ Viewer 1.2.0


    Vielen Dank im Voraus für die Hilfe.


    Gruß


    RSN

  • Moin,

    Ich schaue mir das Problem mal an. Damit es eventuell etwas schneller von statten geht, würde ich dich bitten, mir einmal eine Konversation zu deinem Forum zu senden - am besten und sofern möglich mit FTP Daten.


    Votes: 1

    PHP 7.4 Array Problem

    Sofern man auf PHP 7.4 umsteigt/einstellt wirft das Plugin einen Fehöer in der CacheBuilder Class. Trying to access array offset on value of type bool - in CacheBuilder Line 61.
    Type
    Bug
    Status
    Offen
    Versions
    1.2.0 pl 1
    Assignee
    Last Update
    Oct 5th 2020
    Fixed version
    1.2.0 pl 2 (Future release)
    Components
    de.webexpanded.tsviewer


    LG

  • Weil ich gerade wieder die Meldung erhalten habe wollte ich mal nachfragen, ob du mit die Zugansdaten schon etwas erreichen konntest? Viele Grüße und Danke


  • Guten Morgen,


    ich habe wieder die Meldung bekommen und wollte mich erkundigen, ob du schon etwas erreichen konntest? Sonst würde ich die Zugänge erst mal wieder deaktivieren.


  • Hallo,


    Danke für die schnelle Antwort GangstaSunny . Er hat doch schon Zugriff auf das ACP und FTP, seit dem 06.10.2020. Warum soll ich den noch Screenshots senden? Kann ich zwar gerne machen, allerdings verstehe ich den Sinn nicht.


    Viele Grüße

  • Hallo RSN ,

    bitte entschuldige, häufig werden Zugangsdaten nach Versendung an uns schnell wieder geändert. Ich war mir nicht bewusst, dass diese gleich blieben. Mein Fehler.


    Danke für die Verlinkungen. Wir werden eine separate Testumgebung erstellen in der PHP 7.4 zum Einsatz kommt und dieser Fehler in einer Frischinstallation ohne weitere PHP-Konfigurationen provoziert wird.



    Beste Grüße

  • Die Seite ist uns durchaus bekannt. Es ändert aber nun mal nichts an der Tatsache, dass du bis dato der einzige mit dem Problem bist (von einigen 100 die dieses Plugin nutzen). Wie Sunny bereits schrieb, wir werden eine Testinstanz unter 7.4 installieren und schauen ob wir den Fehler reproduzieren können.


    LG